【威胁通报】Confluence本地文件泄露漏洞(CVE-2019-3394)处置手册

危害等级高,攻击者利用此漏洞可读取<install directory>/confluence/web-inf目录中的任意文件,目前PoC已公开。

漏洞概述

近日,Confluence官方发布了安全通告,修复了存在于 Confluence 中的一处本地文件泄露漏洞(CVE-2019-3394)。

该漏洞存在于Confluence Server和Data Center的页面导出至Word文档功能中。具有创建页面(Add Page)权限的攻击者,可利用该漏洞读取Confluence服务器中<安装目录>/confluence/WEB-INF/目录下包含的任意文件。根据服务器中实际存储的文件内容,该漏洞可能导致泄露以下信息:

  • .jsp文件源代码
  • ./classes目录
  • LDAP认证凭据(位于atlassian-user.xml中)
  • 其他可能存在的敏感信息

 

参考链接:

https://jira.atlassian.com/browse/CONFSERVER-58734

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3394

https://confluence.atlassian.com/doc/confluence-security-advisory-2019-08-28-976161720.html

 

影响范围

受影响版本

  • 6.1.0 <= 版本号 <6.6.16
  • 6.7.0 <= 版本号 <6.13.7
  • 6.14.0 <= 版本号 <6.15.8

 

不受影响版本

  • 6.6.16
  • 6.13.7
  • 6.15.8

 

注:Confluence官方指出Confluence Cloud不受此次通告漏洞影响。

 

影响排查

用户可通过查看当前Confluence版本是否在受影响范围内,对当前服务是否受此漏洞影响进行排查。点击 ,选择“关于Confluence”,即可对当前版本进行查看。

 

修复建议

    • 官方升级

官方建议相关用户升级至最新版本,以保证服务的安全性及稳定性。

  • 确认升级路径,使用Confluence早期版本的用户,可参考下列表格,确认最佳升级路径。
当前版本 推荐升级到 Confluence 的升级路径
2.7或更早版本 升级到 2.7.4 然后升级到 3.5.17,然后按照下面的升级路径。
2.8至3.4 升级到 3.5.17,然后按照下面的升级路径。
3.5 升级到 5.0.3 ,然后升级到最新的 Confluence 6。
4.0至4.3 升级到 5.10.x ,然后升级到最新的 Confluence 6。
5.0至 6.x 直接升级到最新的 Confluence 6。

 

  • 下载Confluence相应版本安装包。

Confluence Server和Data Center下载链接:

https://www.atlassian.com/software/confluence/download

 

  • 备份数据,防止升级失败。

1.用户可进入“设置”->“站点管理”->“备份与还原”,备份Confluence数据。

2.为确保Confluence的完整备份,用户还需通过以下方式手动备份:

  • 数据库备份:

若数据库不支持线上备份,需停止Confluence服务,再进行备份。

 

  • 备份根目录:

  • 移动日常备份文件至系统其他目录:

  • 备份安装目录:

  • 运行安装包,选择“3 Upgrade an existing Confluence installation”,并根据提示进行下一步操作,以版本6.15.8安装包为例:

  • 重启Confluence。

更多关于Confluence的升级细节及注意事项,请参考:https://www.cwiki.us/display/CONF6EN/Upgrading+Confluence

 

临时缓解措施

如暂时无法升级至上述版本,建议采取临时缓解措施

(1)在启动Confluence时,设置参数 -D atlassian.confluence.export.word.max.embedded.images=0 ,将该系统属性值由默认的50调整为0,从而限制无法将图片导出至Word文档;

(2)验证缓解措施是否生效:新建一个包含图片的页面,将其导出至Word,确认导出的Word文件中已经不包含图片。

注:此缓解措施将造成无法把图片导出至Word文档。

 

声明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。

绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。

关于绿盟科技

北京神州绿盟信息安全科技股份有限公司(简称绿盟科技)成立于2000年4月,总部位于北京。在国内外设有30多个分支机构,为政府、运营商、金融、能源、互联网以及教育、医疗等行业用户,提供具有核心竞争力的安全产品及解决方案,帮助客户实现业务的安全顺畅运行。

基于多年的安全攻防研究,绿盟科技在网络及终端安全、互联网基础安全、合规及安全管理等领域,为客户提供入侵检测/防护、抗拒绝服务攻击、远程安全评估以及Web安全防护等产品以及专业安全服务。

北京神州绿盟信息安全科技股份有限公司于2014年1月29日起在深圳证券交易所创业板上市,股票简称:绿盟科技,股票代码:300369。

发表评论