﻿<!DOCTYPE html>
<html lang="zh-CN">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<!--<title>【威胁通告】dotCMS SQL注入漏洞 | 绿盟科技博客</title>-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>【威胁通告】dotCMS SQL注入漏洞 | 绿盟科技博客</title>
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://blog.nsfocus.net/xmlrpc.php">
<link id="favicon" href="http://blog.nsfocus.net/favicon.ico" rel="icon" type="image/x-icon" />


<!-- SEO Ultimate (http://www.seodesignsolutions.com/wordpress-seo/) -->
	<link rel="canonical" href="http://blog.nsfocus.net/dotcms-sql-injection-vulnerability/" />
	<meta name="keywords" content="威胁通报,dotCMS,DotCMS SQL injection vulnerability,dotCMS SQL注入漏洞,dotCMS version,绿盟科技,规避方案,网络安全,NSFOCUS" />

<!-- Code Inserter module -->
<meta name="msvalidate.01" content="28C41EDE5E759D89958A2976CD74FCA6" />
<meta name="baidu-site-verification" content="dAoMq9DcE2" />
<meta name="sogou_site_verification" content="82ChA4GlGU"/>
<meta name="wumiiVerification" content="353f7a48-5689-4c7f-8e7c-ebcb24d4d317" />
<!-- /Code Inserter module -->

<!-- /SEO Ultimate -->

<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel="alternate" type="application/rss+xml" title="绿盟科技博客 &raquo; Feed" href="http://blog.nsfocus.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="绿盟科技博客 &raquo; 评论Feed" href="http://blog.nsfocus.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="绿盟科技博客 &raquo; 【威胁通告】dotCMS SQL注入漏洞评论Feed" href="http://blog.nsfocus.net/dotcms-sql-injection-vulnerability/feed/" />
<link rel='stylesheet' id='validate-engine-css-group-css' href='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css,wp-content/plugins/wp-attachments/styles/0/wpa.css,wp-content/plugins/widget-manager-light/css/otw_sbm.css,wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css,wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css,wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css,wp-content/plugins/post-views-counter/css/frontend.css,wp-content/plugins/wp-category-tag-could/css/wpctc.min.css,wp-content/themes/nsfocus/style.css,wp-content/themes/nsfocus/css/layouts/content-sidebar.css' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container ul li {font-size: 95%;}
</style>
<link rel='stylesheet' id='dashicons-css'  href='http://blog.nsfocus.net/wp-includes/css/dashicons.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='blain-fonts-css'  href='http://blog.nsfocus.net?family=Source+Sans+Pro%3A400%2C600%2C700&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='blain-bootstrap-style-group-css' href='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/themes/nsfocus/css/bootstrap.min.css,wp-content/themes/nsfocus/css/main.css,wp-content/themes/nsfocus/css/nivo/themes/default/default.css,wp-content/themes/nsfocus/css/nivo/nivo.css' type='text/css' media='all' />
<script type='text/javascript' src='http://blog.nsfocus.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://blog.nsfocus.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/themes/nsfocus/js/jquery.timeago.js,wp-content/themes/nsfocus/js/collapse.js,wp-content/themes/nsfocus/js/nivo.slider.js,wp-content/themes/nsfocus/js/superfish.js,wp-includes/js/imagesloaded.min.js,wp-includes/js/masonry.min.js,wp-includes/js/jquery/jquery.masonry.min.js,wp-content/themes/nsfocus/js/bootstrap.min.js,wp-content/themes/nsfocus/js/custom.js'></script>
<link rel='https://api.w.org/' href='http://blog.nsfocus.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://blog.nsfocus.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://blog.nsfocus.net/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='http://blog.nsfocus.net/?p=6758' />
<link rel="alternate" type="application/json+oembed" href="http://blog.nsfocus.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblog.nsfocus.net%2Fdotcms-sql-injection-vulnerability%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://blog.nsfocus.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblog.nsfocus.net%2Fdotcms-sql-injection-vulnerability%2F&#038;format=xml" />
<link type="text/css" rel="stylesheet" href="http://blog.nsfocus.net/wp-content/plugins/category-specific-rss-feed-menu/wp_cat_rss_style.css" />

<link rel="stylesheet" href="http://blog.nsfocus.net/wp-content/plugins/count-per-day/counter.css" type="text/css" />
<style></style><script type="text/javascript" src="http://blog.nsfocus.net/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1487926109"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->
</head>

<body class="post-template-default single single-post postid-6758 single-format-standard group-blog">
<div id="page" class="hfeed site">
		<header id="masthead" class="site-header row container" role="banner">
		<div class="site-branding">
					<div class="site-title"><a href="http://blog.nsfocus.net/" title="" rel="home"></a><span class="site-description"></span></div> 
				</div>	
	</header><!-- #masthead -->

<div class="nav-wrapper container-nav">
    <div class="change_l"></div>
	<nav id="site-navigation" class="navbar navbar-default main-navigation" role="navigation">
			
	    <div class="navbar-header">
		    <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-ex1-collapse">
		      <span class="sr-only">Toggle navigation</span>
		      <span class="icon-bar"></span>
		      <span class="icon-bar"></span>
		      <span class="icon-bar"></span>
		    </button>
		</div>
       
			
			<div class="collapse navbar-collapse navbar-ex1-collapse col-md-6"><ul id="menu-nsfocus" class="nav navbar-nav"><li id="menu-item-4420" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4420"><a title="威胁通报" href="http://blog.nsfocus.net/category/threatalerts/">威胁通报</a></li>
<li id="menu-item-4415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4415"><a title="技术分享" href="http://blog.nsfocus.net/category/techsharing/">技术分享</a></li>
<li id="menu-item-4416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4416"><a title="漏洞分析" href="http://blog.nsfocus.net/category/vulnanalysis/">漏洞分析</a></li>
<li id="menu-item-4417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4417"><a title="运维安全" href="http://blog.nsfocus.net/category/opsafe/">运维安全</a></li>
<li id="menu-item-4418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4418"><a title="安全报告" href="http://blog.nsfocus.net/category/securityreport/">安全报告</a></li>
<li id="menu-item-4419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4419"><a title="Web安全" href="http://blog.nsfocus.net/category/websafe/">Web安全</a></li>
<li id="menu-item-4429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4429"><a title="英文版" href="http://blog.nsfocus.net/tag/englishversion/">英文版</a></li>
</ul></div>                <aside id="search" class="widget widget_search">
                    <form role="search" method="get" class="row search-form" action="http://blog.nsfocus.net/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="搜索 &hellip;" value="" name="s">
		<!-- <span class="icon-search i_span search-submit"  value="<? //php echo esc_attr_x( '', 'submit button', 'blain' ); ?>"></span> -->
	</label>
	
	<input type="submit" class="search-submit" value=" "> 
	 <span class="icon-search i_span"></span>  
</form>
                </aside>
		</nav><!-- #site-navigation -->
		 <div class="h-one hidden-sm hidden-xs"></div> 
		 <div class="h-left hidden-sm hidden-xs">
		 	<a href="http://blog.nsfocus.net/"></a>
		 </div> 
		 <div class="h-right hidden-sm hidden-xs"></div> 

	</div>
	<div id="content" class="site-content row container">
	
	<div id="primary" class="content-area col-md-8">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-6758" class="post-6758 post type-post status-publish format-standard has-post-thumbnail hentry category-threatalerts tag-dotcms tag-dotcms-sql-injection-vulnerability tag-dotcms-sql tag-dotcms-version tag-4 tag-2427">
	<header class="entry-header">
		<h1 class="entry-title">【威胁通告】dotCMS SQL注入漏洞</h1>

		<div class="entry-meta" style="float:left;">
			<span class="posted-on"><i class="icon-time"> </i> <a href="http://blog.nsfocus.net/dotcms-sql-injection-vulnerability/" rel="bookmark"><time class="entry-date published" datetime="2017-02-18T22:28:25+08:00">2017-02-18</time><time class="updated" datetime="2017-02-24T16:45:19+08:00">2017-02-24</time></a></span> <span class="byline"> <i class="icon-user"> </i> <span class="author vcard"><a class="url fn n" href="http://blog.nsfocus.net/author/sushaobo/">苏少博</a></span></span>		</div><!-- .entry-meta -->
		<div class="shared" style="float:left;margin-left:30px;margin-top:-4px;">
			<script>
			(function(){
			    var bp = document.createElement('script');
			    bp.src = '//push.zhanzhang.baidu.com/push.js';
			    var s = document.getElementsByTagName("script")[0];
			    s.parentNode.insertBefore(bp, s);
			})();
			</script>
			<script>
			var _hmt = _hmt || [];
			(function() {
			  var hm = document.createElement("script");
			  hm.src = "//hm.baidu.com/hm.js?a4b04904a9795ac7db74c3920f058bdb";
			  var s = document.getElementsByTagName("script")[0]; 
			  s.parentNode.insertBefore(hm, s);
			})();
			</script>
            <div class="bdsharebuttonbox">
            <a href=" " class="bds_more" data-cmd="more"></a>
            <a href="#" class="bds_tsina" data-cmd="tsina" title="分享到新浪微博"></a>
            <a href="#" class="bds_weixin" data-cmd="weixin" title="分享到微信"></a></a>
            <a href="#" class="bds_qzone" data-cmd="qzone" title="分享到QQ空间"></a></a>
            <a href="#" class="bds_iguba" data-cmd="iguba" title="分享到股吧"></a>	
            </div>
			<script>window._bd_share_config={"common":{"bdSnsKey":{},"bdText":"","bdMini":"2","bdMiniList":false,"bdPic":"","bdStyle":"1","bdSize":"16"},"share":{},"image":{"viewList":["tsina","weixin","renren","qzone","douban","youdao","sqq","iguba"],"viewText":"分享到：","viewSize":"16"},"selectShare":{"bdContainerClass":null,"bdSelectMiniList":["tsina","weixin","renren","qzone","douban","youdao","sqq","iguba"]}};with(document)0[(getElementsByTagName('head')[0]||body).appendChild(createElement('script')).src='http://bdimg.share.baidu.com/static/api/js/share.js?v=89860593.js?cdnversion='+~(-new Date()/36e5)];
			</script>
       </div>
	</header><!-- .entry-header -->

	<div class="entry-content">
		<div class="featured-image-single">
			<img width="554" height="119" src="http://blog.nsfocus.net/wp-content/uploads/2017/02/dotCMS-SQL注入漏洞.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://blog.nsfocus.net/wp-content/uploads/2017/02/dotCMS-SQL注入漏洞.jpg 554w, http://blog.nsfocus.net/wp-content/uploads/2017/02/dotCMS-SQL注入漏洞-300x64.jpg 300w" sizes="(max-width: 554px) 100vw, 554px" />		</div>
		<div class="post-views post-6758 entry-meta">
			<span class="post-views-icon dashicons dashicons-visibility"></span>
			<span class="post-views-label">阅读： </span>
			<span class="post-views-count">118</span>
			</div><p>2017年2月15日，seclists.org网站发布了关于dotCMS存在SQL注入漏洞的消息。文章称，dotCMS 3.6.1及其之前的部分版本，在“/categoriesServlet”的q和inode参数上存在SQL注入，未经身份认证的攻击者可以利用该漏洞获取敏感数据。<span id="more-6758"></span></p>
<p>当dotCMS的版本&lt;=3.3.2时，与之配套使用的MySQL，MSSQL，H2和PostgreSQL受该漏洞影响；当dotCMS的版本为3.5-3.6.1时，如果standard_confirming_strings为禁用时（默认为启用），与之配套使用的MySQL和PostgreSQL受该漏洞影响。相关链接如下：<a href="http://seclists.org/fulldisclosure/2017/Feb/34"><strong>http://seclists.org/fulldisclosure/2017/Feb/34</strong></a></p>
<div id="ez-toc-container" class="counter-hierarchy ez-toc-grey">
<div class="ez-toc-title-container">
<p class="ez-toc-title">文章目录</p>
<span class="ez-toc-title-toggle"><a class="pull-right btn btn-xs btn-default ez-toc-toggle"><i class="glyphicon ez-toc-icon-toggle"></i></a></span></div>
<ul class="ez-toc-list"><li><a href="#dotCMS" title="什么是dotCMS">什么是dotCMS</a></li><li><a href="#i" title="受影响的版本">受影响的版本</a></li><li><a href="#i-2" title="不受影响的版本">不受影响的版本</a></li><li><a href="#i-3" title="规避方案">规避方案</a></li><li><a href="#i-4" title="声 明">声 明</a></li><li><a href="#i-5" title="关于绿盟科技">关于绿盟科技</a></li></ul></div>
<h2><span class="ez-toc-section" id="dotCMS">什么是dotCMS</span></h2>
<p>dotCMS是一个由JAVA语言开发的免费的内容管理系统，开源且跨平台。它可以为网站、移动APP等提供相关平台。在dotCMS中使用到的开源项目与框架有：Apache Tomcat ，Liferay Enterprise Portal ，Apache Struts， Hibernate ORM，Velocity模板语言，Lucene搜索引擎等 。</p>
<h2><span class="ez-toc-section" id="i">受影响的版本</span></h2>
<ul>
<li>dotCMS version &lt;= 3.3.2且数据库为MySQL，MSSQL，H2以及PostgreSQL</li>
<li>dotCMS version 3.5-3.6.1，在standard_confirming_strings为禁用状态且数据库为MySQL、PostgreSQL</li>
</ul>
<h2><span class="ez-toc-section" id="i-2">不受影响的版本</span></h2>
<ul>
<li>dotCMS version = 3.6.2</li>
</ul>
<h2><span class="ez-toc-section" id="i-3">规避方案</span></h2>
<ul>
<li>官方已经发布版本更新，建议用户升级到不受影响的最新版本(3.6.2)；</li>
<li>使用dotCMS 3.5-3.6.1版本的用户，确保stand_confirming_strings函数为启用状态。</li>
</ul>
<h2><span class="ez-toc-section" id="i-4">声 明</span></h2>
<p>本安全公告仅用来描述可能存在的安全问题，绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失，均由使用者本人负责，绿盟科技以及安全公告作者不为此承担任何责任。绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告，必须保证此安全公告的完整性，包括版权声明等全部内容。未经绿盟科技允许，不得任意修改或者增减此安全公告内容，不得以任何方式将其用于商业目的。</p>
<h2><span class="ez-toc-section" id="i-5">关于绿盟科技</span></h2>
<p>北京神州绿盟信息安全科技股份有限公司（简称绿盟科技）成立于2000年4月，总部位于北京。在国内外设有30多个分支机构，为政府、运营商、金融、能源、互联网以及教育、医疗等行业用户，提供具有核心竞争力的安全产品及解决方案，帮助客户实现业务的安全顺畅运行。</p>
<p>基于多年的安全攻防研究，绿盟科技在网络及终端安全、互联网基础安全、合规及安全管理等领域，为客户提供入侵检测/防护、抗拒绝服务攻击、远程安全评估以及Web安全防护等产品以及专业安全服务。</p>
<p>北京神州绿盟信息安全科技股份有限公司于2014年1月29日起在深圳证券交易所创业板上市交易，股票简称：绿盟科技，股票代码：300369。</p>
<p>如果您需要了解更多内容，可以<br />
加入QQ群：570982169<br />
直接询问：010-68438880</p>
<div class="wumii-hook">
    <input type="hidden" name="wurl" value="http://blog.nsfocus.net/dotcms-sql-injection-vulnerability/" /><br />
    <input type="hidden" name="wtitle" value="【威胁通告】dotCMS SQL注入漏洞" /><br />
    <input type="hidden" name="wpic" value="http://blog.nsfocus.net/wp-content/uploads/2017/02/dotCMS-SQL注入漏洞.jpg" />
</div>
<div style="float:right;"></div>			</div><!-- .entry-content -->

	<footer class="entry-meta">
		文章分类： <a href="http://blog.nsfocus.net/category/threatalerts/" rel="category tag">威胁通报</a> <br />文章关键词： <a href="http://blog.nsfocus.net/tag/dotcms/" rel="tag">dotCMS</a>, <a href="http://blog.nsfocus.net/tag/dotcms-sql-injection-vulnerability/" rel="tag">DotCMS SQL injection vulnerability</a>, <a href="http://blog.nsfocus.net/tag/dotcms-sql%e6%b3%a8%e5%85%a5%e6%bc%8f%e6%b4%9e/" rel="tag">dotCMS SQL注入漏洞</a>, <a href="http://blog.nsfocus.net/tag/dotcms-version/" rel="tag">dotCMS version</a>, <a href="http://blog.nsfocus.net/tag/%e7%bb%bf%e7%9b%9f%e7%a7%91%e6%8a%80/" rel="tag">绿盟科技</a>, <a href="http://blog.nsfocus.net/tag/%e8%a7%84%e9%81%bf%e6%96%b9%e6%a1%88/" rel="tag">规避方案</a> <br /> 转载请注明：“转自绿盟科技博客”：  <a href="http://blog.nsfocus.net/dotcms-sql-injection-vulnerability/" rel="bookmark">原文链接</a>.<br />文章收录：<br />
			</footer><!-- .entry-meta -->
</article><!-- #post-## -->
				<nav role="navigation" id="nav-below" class="post-navigation">
		<b class="screen-reader-text">Post navigation</b>

	
		<div class="nav-previous"><a href="http://blog.nsfocus.net/rsa2017-knowledge/" rel="prev"><span class="meta-nav">&larr;</span> RSA2017见闻-不见盒子只见平台情报</a></div>		<div class="nav-next"><a href="http://blog.nsfocus.net/openssl-denial-service-vulnerability/" rel="next">【威胁通告】OpenSSL拒绝服务漏洞 <span class="meta-nav">&rarr;</span></a></div>
	
	</nav><!-- #nav-below -->
	
			
	<div id="comments" class="comments-area">

	
	
		
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">发表评论 <small><a rel="nofollow" id="cancel-comment-reply-link" href="/dotcms-sql-injection-vulnerability/#respond" style="display:none;">取消回复</a></small></h3><p class="must-log-in">要发表评论，您必须先<a href="http://blog.nsfocus.net/wp-login.php?redirect_to=http%3A%2F%2Fblog.nsfocus.net%2Fdotcms-sql-injection-vulnerability%2F">登录</a>。</p>	</div><!-- #respond -->
	
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

	<div id="secondary" class="widget-area col-md-4" role="complementary">
				<aside id="countperday_popular_posts_widget-2" class="widget widget_countperday_popular_posts_widget"><b class="widget-title">绿盟科技博客近期热门</b><ul class="cpd_front_list"><li><a href="http://blog.nsfocus.net?p=2976">学习手册：浅析DDoS的攻击及防御</a> <b>249</b></li>
<li><a href="http://blog.nsfocus.net?p=1291">内存寻址原理</a> <b>192</b></li>
<li><a href="http://blog.nsfocus.net?p=1950">移动APP安全测试要点</a> <b>184</b></li>
<li><a href="http://blog.nsfocus.net?p=505">Dedecms远程写文件漏洞分析</a> <b>184</b></li>
<li><a href="http://blog.nsfocus.net?p=1938">REST API 安全设计指南</a> <b>148</b></li>
</ul></aside><aside id="wysija-2" class="widget widget_wysija"><b class="widget-title">两步邮件订阅，方便获取文章</b><div class="widget_wysija_cont"><div id="msg-form-wysija-2" class="wysija-msg ajax"></div><form id="form-wysija-2" method="post" action="#wysija" class="widget_wysija">

欢迎订阅！现在已有638个朋友订阅了。<br />
在后续邮件的尾部，您可以退订及修改订阅内容。
<p class="wysija-checkbox-label">选择订阅组：</p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="3"  /> 最新文章</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="4"  /> 技术分享</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="5"  /> 漏洞分析</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="7"  /> 运维安全</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="6"  /> Web安全</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="8"  /> 安全报告</label></p>

<p class="wysija-paragraph">
    <label>邮件 <span class="wysija-required">*</span></label>
    
    	<input type="text" name="wysija[user][email]" class="wysija-input validate[required,custom[email]]" title="邮件"  value="" />
    
    
    
    <span class="abs-req">
        <input type="text" name="wysija[user][abs][email]" class="wysija-input validated[abs][email]" value="" />
    </span>
    
</p>
<input class="wysija-submit wysija-submit-field" type="submit" value="马上订阅！" />

    <input type="hidden" name="form_id" value="1" />
    <input type="hidden" name="action" value="save" />
    <input type="hidden" name="controller" value="subscribers" />
    <input type="hidden" value="1" name="wysija-page" />

    
 </form></div></aside><aside id="text-4" class="widget widget_text"><b class="widget-title">绿盟科技博客被dmoz收录</b>			<div class="textwidget"><img src="http://blog.nsfocus.net/wp-content/uploads/2015/09/dmoz-logo.gif">
<a href="http://www.dmoz.org/World/Chinese_Simplified/%E8%AE%A1%E7%AE%97%E6%9C%BA/%E4%BA%92%E8%81%94%E7%BD%91%E7%BB%9C/%E7%BD%91%E7%BB%9C%E8%B5%84%E6%BA%90/%E5%8D%9A%E5%AE%A2/%E6%8A%80%E6%9C%AF" alt="绿盟科技被dmoz收录" target="_blank">.../计算机/互联网络/网络资源/博客/技术</img></a></div>
		</aside>	</div><!-- #secondary -->

	</div><!-- #content -->

	<footer id="colophon" class="site-footer row" role="contentinfo">
	<div class="footer">
			<div class="site-info col-md-4 col-md-offset-3">
			&copy; 2017 <a href="http://www.nsfocus.com">NSFOCUS Corporation</a>, all rights reserved.
		</div><!-- .site-info -->
		
		<!-- <div id="footertext" class="col-md-7"> -->

       	        <!-- </div>   -->
      </div>
       <div class="foot-line"></div>
	</footer><!-- #colophon -->

</div><!-- #page -->

<script type="text/javascript">
// Count per Day
//<![CDATA[
var cpdTime = new Date().getTime() / 1000;
jQuery(document).ready( function()
{
	jQuery.get('/wp-admin/?page=cpd_ajax&f=count&cpage=6758&time='+cpdTime, function(text)
	{
		var cpd_funcs = text.split('|');
		for(var i = 0; i < cpd_funcs.length; i++)
		{
			var cpd_daten = cpd_funcs[i].split('===');
			var cpd_field = document.getElementById('cpd_number_' + cpd_daten[0].toLowerCase());
			if (cpd_field != null) { cpd_field.innerHTML = cpd_daten[1]; }
		}
	});
} );
//]]>
</script><div id="su-footer-links" style="text-align: center;"></div>
<p style="margin:0;padding:0;height:1px;overflow:hidden;">
    <script type="text/javascript"><!--
        var wumiiSitePrefix = "http://blog.nsfocus.net";
        var wumiiEnableCustomPos = false;
        var wumiiParams = "&num=8&mode=3&displayInFeed=1&version=1.0.5.7&pf=WordPress4.7.2";
        var wumiiCategories = ["\u5a01\u80c1\u901a\u62a5"];
    //--></script><script type="text/javascript" src="http://widget.wumii.cn/ext/relatedItemsWidget"></script><a href="http://www.wumii.com/widget/relatedItems" style="border:0;"><img src="http://static.wumii.cn/images/pixel.png" alt="无觅相关文章插件，快速提升流量" style="border:0;padding:0;margin:0;" /></a>
</p><script type='text/javascript'>
/* <![CDATA[ */
var SlimStatParams = {"ajaxurl":"http:\/\/blog.nsfocus.net\/wp-admin\/admin-ajax.php","track_internal_links":"true","extensions_to_track":"pdf,doc,xls,zip","outbound_classes_rel_href_to_not_track":"noslimstat,ab-item","ci":"YTo0OntzOjEyOiJjb250ZW50X3R5cGUiO3M6NDoicG9zdCI7czo4OiJjYXRlZ29yeSI7czozMDoiNzgxLDI4MDgsMjgwNSwyODA2LDI4MDcsNCwyNDI3IjtzOjEwOiJjb250ZW50X2lkIjtpOjY3NTg7czo2OiJhdXRob3IiO3M6ODoic3VzaGFvYm8iO30=.6b21a7045ba1d20619a6d8f8c37a83ad"};
/* ]]> */
</script>
<script type='text/javascript' src='http://cdn.jsdelivr.net/wp/wp-slimstat/trunk/wp-slimstat.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"http:\/\/blog.nsfocus.net\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"\u4f7f\u7528 %s \u590d\u5236\uff0c\u4f7f\u7528 %s \u7c98\u8d34\u3002","minimize":"\u70b9\u51fb\u5c55\u5f00\u4ee3\u7801"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js,wp-content/plugins/wp-category-tag-could/javascript/jquery.tagcanvas.min.js,wp-content/plugins/wp-category-tag-could/javascript/wpctc.tagcanvas.min.js,wp-content/plugins/wp-category-tag-could/javascript/jquery.style.min.js,wp-content/plugins/wp-category-tag-could/javascript/wp-category-tag-cloud.min.js,wp-content/themes/nsfocus/js/navigation.js,wp-content/themes/nsfocus/js/skip-link-focus-fix.js,wp-includes/js/comment-reply.min.js,wp-includes/js/wp-embed.min.js,wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"auto","scroll_offset":"30"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wysijaAJAX = {"action":"wysija_ajax","controller":"subscribers","ajaxurl":"http:\/\/blog.nsfocus.net\/wp-admin\/admin-ajax.php","loadingTrans":"\u52a0\u8f7d\u4e2d...","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js,wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js,wp-content/plugins/easy-table-of-contents/vendor/waypoints/jquery.waypoints.min.js,wp-content/plugins/easy-table-of-contents/assets/js/front.min.js,wp-content/plugins/wysija-newsletters/js/validate/languages/jquery.validationEngine-en.js,wp-content/plugins/wysija-newsletters/js/validate/jquery.validationEngine.js,wp-content/plugins/wysija-newsletters/js/front-subscribers.js'></script>
</body>
</html>

<!-- Dynamic page generated in 0.729 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-02-24 16:48:29 -->

<!-- Super Cache dynamic page detected but late init not set. See the readme.txt for further details. -->
<!-- Dynamic Super Cache -->