﻿<!DOCTYPE html>
<html lang="zh-CN">
<head>
<meta name="360-site-verification" content="b78fb5829391fe29fdeefb55331c20b4"/>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<!--<title>工业控制系统安全服务实施方法设计 | 绿盟科技博客</title>-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>工业控制系统安全服务实施方法设计 | 绿盟科技博客</title>
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://blog.nsfocus.net/xmlrpc.php">
<link id="favicon" href="http://blog.nsfocus.net/favicon.ico" rel="icon" type="image/x-icon" />
<base target="_blank">


<!-- SEO Ultimate (http://www.seodesignsolutions.com/wordpress-seo/) -->
	<link rel="canonical" href="http://blog.nsfocus.net/ics-design/" />
	<meta name="keywords" content="安全分享,ICS安全服务,信息安全服务,工控信息安全,工控信息安全防护,工控安全,工控安全 绿盟,工控安全 防护,工控系统与IT系统的差异,工控系统安全,绿盟 工控,网络安全,绿盟科技,NSFOCUS" />

<!-- Code Inserter module -->
<meta name="msvalidate.01" content="28C41EDE5E759D89958A2976CD74FCA6" />
<meta name="baidu-site-verification" content="dAoMq9DcE2" />
<meta name="sogou_site_verification" content="82ChA4GlGU"/>
<meta name="wumiiVerification" content="353f7a48-5689-4c7f-8e7c-ebcb24d4d317" />
<!-- /Code Inserter module -->

<!-- /SEO Ultimate -->

<link rel="alternate" type="application/rss+xml" title="绿盟科技博客 &raquo; Feed" href="http://blog.nsfocus.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="绿盟科技博客 &raquo; 评论Feed" href="http://blog.nsfocus.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="绿盟科技博客 &raquo; 工业控制系统安全服务实施方法设计评论Feed" href="http://blog.nsfocus.net/ics-design/feed/" />
<link rel='stylesheet' id='validate-engine-css-group-css' href='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css,wp-content/plugins/widget-manager-light/css/otw_sbm.css,wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css,wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css,wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css,wp-content/plugins/post-views-counter/css/frontend.css,wp-content/plugins/wp-category-tag-could/css/wpctc.min.css,wp-content/plugins/wpfront-scroll-top/css/wpfront-scroll-top.min.css,wp-content/themes/nsfocus/style.css,wp-content/themes/nsfocus/css/layouts/content-sidebar.css' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container ul li {font-size: 95%;}
</style>
<link rel='stylesheet' id='dashicons-css'  href='http://blog.nsfocus.net/wp-includes/css/dashicons.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='blain-fonts-css'  href='http://blog.nsfocus.net?family=Source+Sans+Pro%3A400%2C600%2C700&#038;ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='blain-bootstrap-style-group-css' href='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/themes/nsfocus/css/bootstrap.min.css,wp-content/themes/nsfocus/css/main.css,wp-content/themes/nsfocus/css/nivo/themes/default/default.css,wp-content/themes/nsfocus/css/nivo/nivo.css' type='text/css' media='all' />
<script type='text/javascript' src='http://blog.nsfocus.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://blog.nsfocus.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/wpfront-scroll-top/js/wpfront-scroll-top.min.js,wp-content/themes/nsfocus/js/jquery.timeago.js,wp-content/themes/nsfocus/js/collapse.js,wp-content/themes/nsfocus/js/nivo.slider.js,wp-content/themes/nsfocus/js/superfish.js,wp-includes/js/imagesloaded.min.js,wp-includes/js/masonry.min.js,wp-includes/js/jquery/jquery.masonry.min.js,wp-content/themes/nsfocus/js/bootstrap.min.js,wp-content/themes/nsfocus/js/custom.js'></script>
<link rel='https://api.w.org/' href='http://blog.nsfocus.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://blog.nsfocus.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://blog.nsfocus.net/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.1" />
<link rel='shortlink' href='http://blog.nsfocus.net/?p=8968' />
<link rel="alternate" type="application/json+oembed" href="http://blog.nsfocus.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblog.nsfocus.net%2Fics-design%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://blog.nsfocus.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblog.nsfocus.net%2Fics-design%2F&#038;format=xml" />
<link type="text/css" rel="stylesheet" href="http://blog.nsfocus.net/wp-content/plugins/category-specific-rss-feed-menu/wp_cat_rss_style.css" />

<link rel="stylesheet" href="http://blog.nsfocus.net/wp-content/plugins/count-per-day/counter.css" type="text/css" />
<style></style><script type="text/javascript" src="http://blog.nsfocus.net/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1504718405"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code_p { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->

<script>
var _hmt = _hmt || [];
(function() {
  var hm = document.createElement("script");
  hm.src = "https://hm.baidu.com/hm.js?5f7fb43f14fc08b8bd91f2d7c98c412c";
  var s = document.getElementsByTagName("script")[0]; 
  s.parentNode.insertBefore(hm, s);
})();
</script>
<script>
var _hmt = _hmt || [];
(function() {
  var hm = document.createElement("script");
  hm.src = "https://hm.baidu.com/hm.js?751e58969f001fd7bae2fa1c72031f7b";
  var s = document.getElementsByTagName("script")[0]; 
  s.parentNode.insertBefore(hm, s);
})();
</script>

</head>

<body class="post-template-default single single-post postid-8968 single-format-standard group-blog">
<div id="page" class="hfeed site">
		<header id="masthead" class="site-header row container" role="banner">
		<div class="site-branding">
					<div class="site-title"><a href="http://blog.nsfocus.net/" title="" rel="home"></a><span class="site-description"></span></div> 
				</div>	
	</header><!-- #masthead -->

<div class="nav-wrapper container-nav">
    <div class="change_l"></div>
	<nav id="site-navigation" class="navbar navbar-default main-navigation" role="navigation">
			
	    <div class="navbar-header">
		    <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-ex1-collapse">
		      <span class="sr-only">Toggle navigation</span>
		      <span class="icon-bar"></span>
		      <span class="icon-bar"></span>
		      <span class="icon-bar"></span>
		    </button>
		</div>
       
			
			<div class="collapse navbar-collapse navbar-ex1-collapse col-md-6"><ul id="menu-nsfocus" class="nav navbar-nav"><li id="menu-item-6840" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6840"><a title="技术前沿" href="http://blog.nsfocus.net/category/techfront/">技术前沿</a></li>
<li id="menu-item-4420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4420"><a title="威胁通报" href="http://blog.nsfocus.net/category/threatalerts/">威胁通报</a></li>
<li id="menu-item-4418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4418"><a title="安全报告" href="http://blog.nsfocus.net/category/securityreport/">安全报告</a></li>
<li id="menu-item-6841" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6841"><a title="公益译文" href="http://blog.nsfocus.net/category/publicwelfare/">公益译文</a></li>
<li id="menu-item-4419" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4419"><a title="安全分享" href="http://blog.nsfocus.net/category/safeshare/">安全分享</a></li>
<li id="menu-item-6839" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6839"><a title="安全意识" href="http://blog.nsfocus.net/category/securityawareness/">安全意识</a></li>
<li id="menu-item-4429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4429"><a title="英文版" href="http://blog.nsfocus.net/tag/englishversion/">英文版</a></li>
</ul></div>                <aside id="search" class="widget widget_search">
                    <form role="search" method="get" class="row search-form" action="http://blog.nsfocus.net/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="搜索 &hellip;" value="" name="s">
		<!-- <span class="icon-search i_span search-submit"  value="<? //php echo esc_attr_x( '', 'submit button', 'blain' ); ?>"></span> -->
	</label>
	
	<input type="submit" class="search-submit" value=" "> 
	 <span class="icon-search i_span"></span>  
</form>
                </aside>
		</nav><!-- #site-navigation -->
		 <div class="h-one hidden-sm hidden-xs"></div> 
		 <div class="h-left hidden-sm hidden-xs">
		 	<a href="http://blog.nsfocus.net/"></a>
		 </div> 
		 <div class="h-right hidden-sm hidden-xs"></div> 

	</div>
	<div id="content" class="site-content row container">
	
	<div id="primary" class="content-area col-md-8">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-8968" class="post-8968 post type-post status-publish format-standard has-post-thumbnail hentry category-safeshare tag-ics tag-4137 tag-3008 tag-1955 tag-811 tag-4099 tag-2366 tag-it tag-1949 tag-4096">
	<header class="entry-header">
		<h1 class="entry-title">工业控制系统安全服务实施方法设计</h1>

		<div class="entry-meta" style="float:left;">
			<span class="posted-on"><i class="icon-time"> </i> <a href="http://blog.nsfocus.net/ics-design/" rel="bookmark"><time class="entry-date published" datetime="2017-09-06T10:19:49+08:00">2017-09-06</time><time class="updated" datetime="2017-09-06T15:48:30+08:00">2017-09-06</time></a></span> <span class="byline"> <i class="icon-user"> </i> <span class="author vcard"><a class="url fn n" href="http://blog.nsfocus.net/author/pangnan/">庞南</a></span></span>		</div><!-- .entry-meta -->
		<div class="shared" style="float:left;margin-left:30px;margin-top:-4px;">
			<script>
			(function(){
			    var bp = document.createElement('script');
			    bp.src = '//push.zhanzhang.baidu.com/push.js';
			    var s = document.getElementsByTagName("script")[0];
			    s.parentNode.insertBefore(bp, s);
			})();
			</script>
			<script>
			var _hmt = _hmt || [];
			(function() {
			  var hm = document.createElement("script");
			  hm.src = "//hm.baidu.com/hm.js?a4b04904a9795ac7db74c3920f058bdb";
			  var s = document.getElementsByTagName("script")[0]; 
			  s.parentNode.insertBefore(hm, s);
			})();
			</script>
            <div class="bdsharebuttonbox">
            <a href=" " class="bds_more" data-cmd="more"></a>
            <a href="#" class="bds_tsina" data-cmd="tsina" title="分享到新浪微博"></a>
            <a href="#" class="bds_weixin" data-cmd="weixin" title="分享到微信"></a></a>
            <a href="#" class="bds_qzone" data-cmd="qzone" title="分享到QQ空间"></a></a>
            <a href="#" class="bds_iguba" data-cmd="iguba" title="分享到股吧"></a>	
            </div>
			<script>window._bd_share_config={"common":{"bdSnsKey":{},"bdText":"","bdMini":"2","bdMiniList":false,"bdPic":"","bdStyle":"1","bdSize":"16"},"share":{},"image":{"viewList":["tsina","weixin","renren","qzone","douban","youdao","sqq","iguba"],"viewText":"分享到：","viewSize":"16"},"selectShare":{"bdContainerClass":null,"bdSelectMiniList":["tsina","weixin","renren","qzone","douban","youdao","sqq","iguba"]}};with(document)0[(getElementsByTagName('head')[0]||body).appendChild(createElement('script')).src='http://bdimg.share.baidu.com/static/api/js/share.js?v=89860593.js?cdnversion='+~(-new Date()/36e5)];
			</script>
       </div>
	</header><!-- .entry-header -->

	<div class="entry-content">
		<div class="featured-image-single">
			<img width="2598" height="1890" src="http://blog.nsfocus.net/wp-content/uploads/2017/09/工控安全.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://blog.nsfocus.net/wp-content/uploads/2017/09/工控安全.jpg 2598w, http://blog.nsfocus.net/wp-content/uploads/2017/09/工控安全-300x218.jpg 300w, http://blog.nsfocus.net/wp-content/uploads/2017/09/工控安全-768x559.jpg 768w, http://blog.nsfocus.net/wp-content/uploads/2017/09/工控安全-1024x745.jpg 1024w, http://blog.nsfocus.net/wp-content/uploads/2017/09/工控安全-600x436.jpg 600w" sizes="(max-width: 2598px) 100vw, 2598px" />		</div>
		<div class="post-views post-8968 entry-meta">
			<span class="post-views-icon dashicons dashicons-visibility"></span>
			<span class="post-views-label">阅读： </span>
			<span class="post-views-count">29</span>
			</div><p>在不同行业客户中，由于行业业务属性存在较大差异，应用场景差异也不小，这就需要尽量贴近行业业务特点，给出有针对性的行业解决方案，同时还应当建立起一套用于规范工控安全服务工程实施的方法论，本文尝试提出一种工控安全服务实施方法的设计思路。</p>
<p><span id="more-8968"></span></p>
<div id="ez-toc-container" class="counter-hierarchy ez-toc-grey">
<div class="ez-toc-title-container">
<p class="ez-toc-title">文章目录</p>
<span class="ez-toc-title-toggle"><a class="pull-right btn btn-xs btn-default ez-toc-toggle"><i class="glyphicon ez-toc-icon-toggle"></i></a></span></div>
<ul class="ez-toc-list"><li><a href="#i" title="引言">引言</a></li><li><a href="#1" title="1 信息系统安全保障方法论回顾">1 信息系统安全保障方法论回顾</a></li><li><a href="#2" title="2 工控安全项目推进面临的挑战">2 工控安全项目推进面临的挑战</a><ul><li><a href="#21" title="2.1工控系统环境的行业性差异">2.1工控系统环境的行业性差异</a></li><li><a href="#22_ICSIT" title="2.2 ICS与IT系统的体系架构差异">2.2 ICS与IT系统的体系架构差异</a></li><li><a href="#23" title="2.3 服务实施方法论成熟度">2.3 服务实施方法论成熟度</a></li></ul></li><li><a href="#3" title="3 工控安全服务方法论">3 工控安全服务方法论</a><ul><li><a href="#31" title="3.1服务过程">3.1服务过程</a></li><li><a href="#32" title="3.2任务步骤">3.2任务步骤</a><ul><li><a href="#321_ICS" title="3.2.1 ICS应用调研">3.2.1 ICS应用调研</a></li><li><a href="#322" title="3.2.2 安全域划分">3.2.2 安全域划分</a></li><li><a href="#323" title="3.2.3 安全控制基线构造">3.2.3 安全控制基线构造</a></li><li><a href="#324" title="3.2.4 差距分析">3.2.4 差距分析</a></li><li><a href="#325" title="3.2.5 建设方案编写">3.2.5 建设方案编写</a></li></ul></li></ul></li><li><a href="#5" title="5 小结">5 小结</a></li><li><a href="#i-2" title="参考文献">参考文献</a></li></ul></div>
<h2><span class="ez-toc-section" id="i">引言</span></h2>
<p>工业控制系统（ICS）在传统上凭借封闭的专有协议，以及与外部其它网络环境相独立，即便与之配套的安全控制机制普遍设计不足，通常意义上也被认为安全风险水平较低，其安全保障并未得到应有的足够重视。</p>
<p>伴随着工业化与信息化的融合，信息技术已经成为工业系统的重要支撑力量，而随之而来的，安全威胁和安全风险显著提高。近年来频繁曝光的与工业控制系统相关的安全事件，其中以2010年伊朗核电站Stuxnet震网病毒事件在全球范围内引起了对工业控制系统安全的重视，西方国家尤其是美国从90年代开始已经开始了针对工业控制系统安全的研究，在各个行业相继出台了标准规范来指导工业控制系统安全的建设。发生在2015年的乌克兰电网Blackenergy恶意软件事件为工业控制系统安全又一次敲响了警钟，而且由于广泛使用工业控制系统的行业通常是关系到国计民生的重点行业，各国政府也对工业控制系统的安全保障给予越来越高的重视。</p>
<p>我国自2008年正式发布标准，推行信息系统安全等级保护政策以来，为适应信息技术和应用的发展趋势，于2015年开始组织对等级保护基本要求进行全面修订更新，面向若干新领域和新场景有针对性地提出了安全保护扩展要求，其中就包括了工业控制系统场景。另外相当数量的工业控制系统属于2016年11月正式颁布的《中华人民共和国网络安全法》中所界定的关键信息基础设施，网络安全法将对关键信息基础设施的安全保障提高到了国家法律的高度，也证明了国家对于工业控制系统的安全保障给予了空前的重视。</p>
<p>公司对工控安全领域进行了持续的技术跟踪和研究积累，产品线在2016年正式成立了工控安全产品团队，着力于研究相关标准、设计工控安全解决方案、研发工控安全产品。业务线致力于响应和挖掘行业客户的工控安全需求，并促成项目落地。我们在了解和接触到的一些工控安全项目机会中，深深感触到工控系统在不同行业客户中的应用场景因为行业业务属性的区别而存在较大差异，为尽量贴近行业业务特点给出有针对性的行业解决方案，不仅需要对不同行业工控系统环境进行深入调研和理解，还应当建立起一套用于规范工控安全服务工程实施的方法论，本文尝试提出一种工控安全服务实施方法的设计思路。</p>
<h2><span class="ez-toc-section" id="1">1 信息系统安全保障方法论回顾</span></h2>
<p>首先，我们来回顾一下IT信息系统的安全保障思路。我们暂且不去考虑更高层次的周期性安全风险管理过程，以及由被称为最佳实践的安全管理控制措施构成的所谓安全管理体系，仅从信息系统的安全技术保障方面来讲，面向安全域的纵深防御是得到最普遍认可的工程方法，无论是自1998年发布并且多次修订更新的信息保障技术框架IATF，还是在国内广泛实施的信息系统安全等级保护系列标准，这一思想在众多的权威标准规范中都得到了体现。</p>
<p>我们在为一个特定的网络和信息系统设计安全保障技术方案时，通常都会遵循和执行以下的工程步骤：</p>
<ul>
<li>调研信息系统所在的网络环境结构，以及信息系统的构成组件和工作机制，从而能够理解网络拓扑机构、信息系统的软硬件资产构成及其在网络中的部署位置、信息系统不同组件之间的通信机理和数据流转情况。</li>
<li>对网络和信息系统进行安全域划分，安全域的划分依据是信息系统及其组件的重要性级别不同，安全域划分的表现形式通常是划分出代表不同安全级别的网络安全域，同一安全域内部分布的信息资产往往具备相同的安全级别，并适用于一致的安全策略。</li>
<li>对某一个特定的安全域，需要从边界防护、域内计算环境保护、以及跨越边界的数据安全传输等三方面选择适当的安全技术控制措施，以达成安全保障目标。所选择的安全控制措施不仅要适应IT信息系统的层次化特点，全面覆盖物理环境、网络、系统、应用、数据等层面，还应当符合信息保障要求，通常遵循PDRR安全模型，兼顾事先预防型（Protection）、事发检测型（Detection）和响应型（Reaction）、事后恢复型（Recovery）等不同类型。选择安全技术控制措施的依据由风险评估的结果决定的安全需求和合规性要求两方面组成，而一些权威性的安全标准规范（例如NIST SP800-53和GB/T 22039信息系统安全等级保护基本要求）则提供了安全技术控制措施的参考基线，其中包含了大量可供选择的安全控制措施。</li>
<li>以确定需要采用的、同时当前系统环境中未部署的安全技术控制措施为基础，编写安全技术设计和实施方案，用于指导后续的安全项目建设。</li>
</ul>
<p>通过上述步骤我们可以看出，在开始以具体的安全产品或安全系统完成安全项目交付之前，为了能够有效贴合特定网络和信息系统的实际情况，给出有针对性的安全设计方案，需要完成系统调研、风险评估、安全域划分、控制措施选择、甚至安全基线差距分析等一系列工作过程，而这一过程通常是由专业人员以服务的方式完成。</p>
<h2><span class="ez-toc-section" id="2">2 工控安全项目推进面临的挑战</span></h2>
<p>在响应行业客户的工控安全需求，推进工控安全项目落地的过程中，当前面临着几个方面的挑战。</p>
<h3><span class="ez-toc-section" id="21">2.1工控系统环境的行业性差异</span></h3>
<p>按照工业企业生产工艺的组织方式，通常将工业企业区分为流程工业和离散制造业两类。</p>
<ul>
<li>流程生产企业的生产方式，主要是通过对原材料进行混合、分离、粉碎、加热等物理或化学方法，使原材料增值。典型的流程生产行业有医药、石油化工、电力、钢铁制造、石油化工、水泥等领域。</li>
<li>离散制造企业的生产方式，主要是通过对原材料物理形状的改变、组装，成为产品，使其增值。典型的离散制造行业主要包括机械制造、电子电器、航空制造、汽车制造等行业。</li>
</ul>
<p>业务线所覆盖的行业客户中，广泛建设和使用工业控制系统的典型行业包括电力（发电与输电）、石油化工、燃气、煤炭、冶金、机械制造、家用电器制造、汽车制造、市政水务处理、轨道交通、港口码头、水利管理、道路交通管理、军工制造等，由于生产的产品类型不同，其工业制造过程在产品结构、工艺流程、作业调度等方面都存在着非常显著的行业化差异，由此所导致的工业控制系统的体系架构、组件构成、应用模式也存在着同行业内相似度较高，不同行业之间差异较大的现状。</p>
<p>出于安全服务于业务的基本原则，为促进工控安全项目的有效推进和落地交付，需要对各个重点行业客户的生产过程和工控系统应用情况进行深入细致的调研，充分理解特定行业客户的生产过程、控制需求以及工控系统的架构组成、部署和使用模式，才能够真正做到理解客户业务，继而有效识别安全缺陷，给出有针对性的安全建议。</p>
<p>因为工业控制系统的行业化差异，决定了不可能有所谓通用的工控安全解决方案，而是必须面向不同的行业业务特点和控制系统应用模式，制定行业化的工控安全解决方案。</p>
<h3><span class="ez-toc-section" id="22_ICSIT">2.2 ICS与IT系统的体系架构差异</span></h3>
<p>区别于单纯的IT系统，工业控制系统ICS因为使用IT技术的同时，还涉及对于物理组件的控制，更加接近于德国工业4.0和中国制造2025等战略规划中“两化融合”的核心概念—信息物理系统CPS。目前已经有了众多论述涉及ICS与IT系统的比较和差异，两者在系统性能、通信协议、风险管理、运维模式、事件影响、应急处置、系统生命周期等方面都存在着众多明显的差异。</p>
<p>鉴于以上原因，习惯性使用面向IT系统进行安全分析和保障的思路显然并不恰当，必须要从ICS系统自身的架构和体系模型出发，或者说从工业控制系统的视角来看待工控安全问题，才能真正做到有的放矢。当务之急是建立工控系统及其安全保障的知识体系，实现从IT视角向ICS视角的转换。</p>
<h3><span class="ez-toc-section" id="23">2.3 服务实施方法论成熟度</span></h3>
<p>一方面由于工控系统安全保障仍属新兴专业领域，另一方面由于工控安全领域的标准规范还在陆续推出，其提供的工程实施方法论也处于完善过程之中，因此工控安全服务方法也需要摸索和总结，才能有效支撑工控安全项目的实施。</p>
<h2><span class="ez-toc-section" id="3">3 工控安全服务方法论</span></h2>
<p>按照安全保障PDCA过程方法论，在真正开始实施具体的安全控制措施之前，应当对保障对象及其安全保障的现状调研、与权威安全基线之间的差距分析，继而输出针对特定安全保障对象的安全建议，并对安全建议内容进行合理的规划。因此，特定ICS的安全保障项目应该从一个服务过程开始，然后再进入后续的具体安全产品的采购和部署，是一个更加合理的次序。</p>
<p>本文提出的ICS安全服务过程的设计，能够提供一种工程方法指导。从服务过程角度，ICS的安全服务过程与IT系统安全服务过程比较类似，但是具体深入到其中的服务步骤中时，由于ICS与IT系统之间的差异，服务实施的具体方法会存在着显著的不同。</p>
<h3><span class="ez-toc-section" id="31">3.1服务过程</span></h3>
<p>首先，ICS的安全服务过程应该优先于ICS的安全实施过程。其次，ICS项目的安全服务过程，一共包括了ICS应用调研、安全域划分、安全控制基线构造、差距分析、建设方案编写等5个服务步骤。</p>
<p><img class="aligncenter" src="http://blog.nsfocus.net/wp-content/uploads/2017/09/70f02c0bf8c5c7eb9a0976e0629a2e0a.png" title="" alt="" /></p>
<p style="text-align: center;"><em>图1 工控安全服务过程</em></p>
<h3><span class="ez-toc-section" id="32">3.2任务步骤</span></h3>
<h4><span class="ez-toc-section" id="321_ICS">3.2.1 ICS应用调研</span></h4>
<p>对IT应用的服务过程中，现状调研步骤的关注重点包括网络拓扑结构、应用类型、支撑应用的软硬件资产在不同的网络区域中的分布、以及部署在网络环境中的安全技术措施等，现状调研步骤的输出物包括了体现了信息资产分布的网络拓扑图、软硬件信息资产清单、以及信息资产的各组件在网络拓扑图中的数据流图等。</p>
<p>ICS应用与传统的IT应用之间的最显著区别在于，虽然两者都会涉及到过程控制，但是IT系统通过软件所实现的过程控制，完全是抽象实现于IT系统的各组件之间的逻辑过程，而ICS应用所实现的过程控制通常都是按照工艺流程，对对物理设施实现的实际控制过程。这点区别决定了，不能够用IT应用的视角去看待ICS，ICS的架构描述需要从其自身的视角用专门的模型去完成。</p>
<p>IEC 62264是关于企业控制系统集成的一个标准族，该标准在2006年被等同采纳为GB/T 20720国家标准，该标准族的第一部分引用了普渡大学的CIM参考模型所提供的层次结构模型和功能数据流模型，来描述工业企业生产控制系统的通用架构和工作机制，尤其是其中的层次结构模型，为我们从正确视角看待ICS的体系架构提供了重要参考。</p>
<p>新修订的面向工业控制系统的等级保护扩展要求，在GB/T20720标准提供的层次结构模型基础之上，将ICS中SCADA、DCS、PLC等系统的共性进行了抽象，依次归纳出逐级细化的功能层次模型、功能单元映射模型、和资产组件映射模型，其中前两个模型都包括了5个抽象层次，第三个模型只包括5个抽象层次的下面四个层次，这是因为第五层企业资源层的系统并非ICS，而是属于传统IT系统的范畴。</p>
<p><img class="aligncenter" src="http://blog.nsfocus.net/wp-content/uploads/2017/09/e53b8ffc5caf4981d37035572434d130.png" title="" alt="" /></p>
<p style="text-align: center;"><em>图2 工业控制功能层次模型</em></p>
<p><img class="aligncenter" src="http://blog.nsfocus.net/wp-content/uploads/2017/09/2458ad6edc7ec9c7b00fcf61b3b3159f.png" title="" alt="" /></p>
<p style="text-align: center;"><em>图3 工业控制功能单元映射模型</em></p>
<p><img class="aligncenter" src="http://blog.nsfocus.net/wp-content/uploads/2017/09/d349146ea49bcf1164265354a83833c2.png" title="" alt="" /></p>
<p style="text-align: center;"><em>图4 工业控制资产组件映射模型</em></p>
<p>         在对特定客户的ICS应用进行调研时，应当参考功能层次模型，从企业资源层、生产管理层、过程控制层、现场控制层、及现场设备层这5个不同层次，对每个层次中的功能单元和支撑功能实现的资产组件进行调查和汇总，最终用功能单元映射模型和资产组件映射模型，来描述这个特定ICS的体系架构和资产组件构成。</p>
<p>ICS应用调研步骤的输出结果应当包括：</p>
<ul>
<li>功能单元与资产组件映射详图</li>
<li>资产组件清单</li>
<li>管理机制描述</li>
</ul>
<h4><span class="ez-toc-section" id="322">3.2.2 安全域划分</span></h4>
<p>虽然描述IT系统和ICS的架构模型方法、以及资产组件构成不同，但是从安全保障的基本原则和思路方面，两者又是非常类似。几乎所有面向工业控制系统安全保障的权威标准，不论是NIST SP800-82R2、IEC62443、还是新修订的面向工业控制系统的等级保护扩展要求，都提出了对ICS划分安全域，并且按照纵深防御的原则选择适当的安全技术措施对安全域的边界和内部计算环境进行安全防护的整体思路，这一思路与IT系统的安全保障思路如出一辙。</p>
<p>IT网络和系统的安全域划分，通常以网络区域的形式体现，不同的网络区域，代表着不同的安全级别，分布着重要性不同的信息资产，每一个安全域适用于一个统一的安全防护策略。</p>
<p>IEC 62443-1标准提供了工业通信网络和系统安全的概念和模型，其中给出了安全域的划分方法描述，新修订的面向工业控制系统的等级保护扩展要求引用了IEC62443-1的安全域划分方法，并且给出了典型的DCS系统和SCADA系统的安全域划分示例。</p>
<p>下图为典型的工业化生产企业DCS系统结构图，该图将企业内整个网络和系统分为五个层次，包括企业资源层、生产管理层、过程监控层、现场控制层和现场设备层，其中企业资源层和生产管理层为传统的IT系统，而过程控制层、现场控制层以及现场设备层为工业控制系统，与IT系统有着截然不同的安全需求。一般将企业资源层划分为两个安全域，一个安全域包含的是所有面对互联网提供的公共服务，另一个安全域包含的是所有面对内联网提供的内部服务。在现场层一般会将不同工艺的工业化设备划分为独立的安全域，并通过开放的opc服务与上层进行数据交互。</p>
<p><img class="aligncenter" src="http://blog.nsfocus.net/wp-content/uploads/2017/09/fe663c6ed56401c1eaf33fbd88e4671d.png" title="" alt="" /></p>
<p style="text-align: center;"><em>图4 DCS系统安全域划分</em></p>
<p>下图为典型的电力行业调度中心与智能化变电站SCADA系统结构图，调度中心与智能变电站通过IP认证加密装置进行纵向联系，根据调度中心和智能变电站的功能特点，调度中心被划分为企业资源层和生产管理层，智能变电站被划分为站控层、间隔层和过程层，分别对应到工业化控制企业的过程监控层、现场控制层和现场设备层。在智能变电站内部根据系统的实时性要求不同，又被划分为实时控制区和非实时控制区。</p>
<p><img class="aligncenter" src="http://blog.nsfocus.net/wp-content/uploads/2017/09/bc74323680e2f882e405c2135dd0dbb3.png" title="" alt="" /></p>
<p style="text-align: center;"><em>图5 SCADA系统安全域划分</em></p>
<p>对ICS进行安全域划分的结果，可能包含两种情况</p>
<ul>
<li>层内域，即划分出的安全域范围仅涉及ICS层次结构模型中的某一层次</li>
<li>层间域，即划分出的安全域范围同时包括了ICS层级结构模型中的两个或多个层次</li>
</ul>
<p>以上两种类型的安全域在后续提供安全保障措施时，存在一定的差异，相对于层内域，层间域一方面因为包含了多个层次而减少了需要保障的安全域边界数量，另一方面又因为包含了多个层次结构，而需要在域内环境保护方面，同时考虑对其中每一个特定层次结构的安全控制措施。</p>
<p>ICS安全域划分步骤的输出成果为建立在资产组件映射图基础上的《ICS安全域划分示意图》。</p>
<h4><span class="ez-toc-section" id="323">3.2.3 安全控制基线构造</span></h4>
<p>任何系统的安全保障目标都是通过部署和使用一系列适当的安全控制措施才能达成，ICS的安全保障也不例外。几乎所有与ICS安全保障有关的权威标准、规范和指南，都是面对划分好的安全域，从安全域边界隔离和防护、安全域内部计算环境安全控制等方面，提供了可供使用或者要求具备的安全技术控制措施集合。         例如：</p>
<ul>
<li>《NIST SP800-82R2工业控制系统安全指南》用第五章来专门阐述ICS的安全体系架构和推荐的安全控制措施；</li>
<li>2016年发布的《GB/T32919 工业控制系统安全控制应用指南》在第六章阐述了安全控制基线的设计方法，并在附录B中用较大的篇幅给出了推荐的共计18类安全技术控制措施和安全管理控制措施列表；</li>
<li>新修订的《网络安全等级保护基本要求第5部分 工业控制系统的等级保护扩展要求》中要求根据定级对象的等级保护级别和划分好的安全域，分别针对安全域可能涉及的工控系统层次结构的下4层，给出了安全技术控制措施的扩展要求。</li>
</ul>
<p>应当对上述的多项标准规范所提供的安全控制措施基线建立深入的理解，并在任何一个特定的ICS项目安全服务过程中，根据服务对象的实际情况，为ICS建立应有的安全保障控制措施基线，其中所采取的控制措施，一方面是为了符合合规性要求（例如等级保护要求），另一方面是在实践中被证明对控制ICS安全风险行之有效的最佳实践经验。</p>
<p>特定的ICS项目安全服务过程，在构造安全控制措施基线时，可以分两种模式进行：</p>
<ul>
<li>当ICS的安全保障特别注重等级保护合规时，可以直接根据等级保护级别和安全域中的功能层次，从《网络安全等级保护基本要求第5部分 工业控制系统的等级保护扩展要求》提供的控制措施基线中选取特定安全域应该具备的安全技术控制措施，一个完整ICS的安全保障，体现在对每个安全域的安全保障基础之上。另外，从《网络安全等级保护基本要求》中选择对应等级保护级别的安全管理措施，与确定好的安全技术措施共同组成ICS安全基线，需要特别指出的是，安全技术措施是面向组成ICS的每个安全域的，而安全管理措施通常是面向整个ICS的。</li>
<li>当ICS的安全保障不以等级保护合规为主要目的，而是要求尽可能全面有效控制ICS面对的安全风险，那么可以借鉴《网络安全等级保护基本要求第5部分 工业控制系统的等级保护扩展要求》中针对每个安全域的不同功能层次建立安全控制措施的思想，但是在具体的控制措施选择上，不需要局限于等级保护标准，而是同时参考多项安全标准规范，尤其是客户所属行业的工控安全规范，将其中有价值的控制措施识别并合并，提炼出一套融合了多个标准的更加完整的控制措施基线。</li>
</ul>
<p>本服务步骤的输出成果为面向某特定ICS的《安全控制措施基线》。</p>
<p><em>【说明】本文旨在对</em><em>ICS</em><em>安全服务过程和主要步骤的工作思路进行整理和归纳，因此未去涉及具体的</em><em>ICS</em><em>安全控制措施基线的具体分析和详细设计，这部分工作将在后续的技术文章中进行阐述。</em></p>
<h4><span class="ez-toc-section" id="324">3.2.4 差距分析</span></h4>
<p>在本服务步骤中，要将前期对ICS应用及其安全保障现状的调研结果与设定好的安全控制措施基线进行逐项比较，从而识别出ICS的安全保障现状与基线要求之间的差距。</p>
<p>本服务步骤的工作与IT系统安全差距分析的做法非常类似，输出成果为《ICS安全基线差距分析报告》。</p>
<h4><span class="ez-toc-section" id="325">3.2.5 建设方案编写</span></h4>
<p>在本服务步骤中，根据前期工作输出的安全基线差距分析报告，可以识别出当前ICS在安全保障方面的不足，所有安全基线中要求的、而当前又不满足的技术措施和管理措施，都应当被合并构成后续的安全建设内容。</p>
<p>需要说明的是，多项安全建设内容可能受限于可投入资源规模，而需要分期建设，因此《ICS安全建设方案》应该考虑到将建议的建设内容，合理进行规划，给出分步有序的建设路线图建议。</p>
<h2><span class="ez-toc-section" id="5">5 小结</span></h2>
<p>本文基于对多个权威标准规范的深入学习理解，并结合ICS安全项目经验， 介绍ICS与IT系统在架构方面的差异，分析了在实际工程项目中面临的挑战，然后提出了一种ICS安全服务过程的设计方法，对特定ICS安全项目的工程实施过程具备参考和指导意义。</p>
<h2><span class="ez-toc-section" id="i-2">参考文献</span></h2>
<p>[1] 《GB/T 20720.1-2006/IEC62264.1-2013企业控制系统集成第1部分 模型和术语》</p>
<p>[2] 《NIST SP800-82R2工业控制系统安全指南》</p>
<p>[3] 《GB/T32919-2016 工业控制系统安全控制应用指南》</p>
<p>[4] 《网络安全等级保护基本要求第5部分 工业控制系统的等级保护扩展要求》</p>
<p>[5] 《IEC 62443-1-1 工业通信网络 网络和系统安全 第1-1部分 术语、概念和模型》</p>
<div class="wumii-hook">
    <input type="hidden" name="wurl" value="http://blog.nsfocus.net/ics-design/" /><br />
    <input type="hidden" name="wtitle" value="工业控制系统安全服务实施方法设计" /><br />
    <input type="hidden" name="wpic" value="http://blog.nsfocus.net/wp-content/uploads/2017/09/工控安全.jpg" />
</div>
<div style="float:right;"></div>			</div><!-- .entry-content -->

	<footer class="entry-meta">
		文章分类： <a href="http://blog.nsfocus.net/category/safeshare/" rel="category tag">安全分享</a> <br />文章关键词： <a href="http://blog.nsfocus.net/tag/ics%e5%ae%89%e5%85%a8%e6%9c%8d%e5%8a%a1/" rel="tag">ICS安全服务</a>, <a href="http://blog.nsfocus.net/tag/%e4%bf%a1%e6%81%af%e5%ae%89%e5%85%a8%e6%9c%8d%e5%8a%a1/" rel="tag">信息安全服务</a>, <a href="http://blog.nsfocus.net/tag/%e5%b7%a5%e6%8e%a7%e4%bf%a1%e6%81%af%e5%ae%89%e5%85%a8/" rel="tag">工控信息安全</a>, <a href="http://blog.nsfocus.net/tag/%e5%b7%a5%e6%8e%a7%e4%bf%a1%e6%81%af%e5%ae%89%e5%85%a8%e9%98%b2%e6%8a%a4/" rel="tag">工控信息安全防护</a>, <a href="http://blog.nsfocus.net/tag/%e5%b7%a5%e6%8e%a7%e5%ae%89%e5%85%a8/" rel="tag">工控安全</a>, <a href="http://blog.nsfocus.net/tag/%e5%b7%a5%e6%8e%a7%e5%ae%89%e5%85%a8-%e7%bb%bf%e7%9b%9f/" rel="tag">工控安全 绿盟</a>, <a href="http://blog.nsfocus.net/tag/%e5%b7%a5%e6%8e%a7%e5%ae%89%e5%85%a8-%e9%98%b2%e6%8a%a4/" rel="tag">工控安全 防护</a>, <a href="http://blog.nsfocus.net/tag/%e5%b7%a5%e6%8e%a7%e7%b3%bb%e7%bb%9f%e4%b8%8eit%e7%b3%bb%e7%bb%9f%e7%9a%84%e5%b7%ae%e5%bc%82/" rel="tag">工控系统与IT系统的差异</a>, <a href="http://blog.nsfocus.net/tag/%e5%b7%a5%e6%8e%a7%e7%b3%bb%e7%bb%9f%e5%ae%89%e5%85%a8/" rel="tag">工控系统安全</a>, <a href="http://blog.nsfocus.net/tag/%e7%bb%bf%e7%9b%9f-%e5%b7%a5%e6%8e%a7/" rel="tag">绿盟 工控</a> <br /> 转载请注明：“转自绿盟科技博客”：  <a href="http://blog.nsfocus.net/ics-design/" rel="bookmark">原文链接</a>.<br />文章收录：<br />
			</footer><!-- .entry-meta -->
</article><!-- #post-## -->
				<nav role="navigation" id="nav-below" class="post-navigation">
		<b class="screen-reader-text">Post navigation</b>

	
		<div class="nav-previous"><a href="http://blog.nsfocus.net/s2-052-struts2-remote-code-execution-vulnerability-4/" rel="prev"><span class="meta-nav">&larr;</span> 【预警通告】Apache Struts2（S2-052）远程代码执行漏洞</a></div>		<div class="nav-next"><a href="http://blog.nsfocus.net/finance-unknown-threat-detection/" rel="next">金融行业未知威胁检测探知之道 <span class="meta-nav">&rarr;</span></a></div>
	
	</nav><!-- #nav-below -->
	
			
	<div id="comments" class="comments-area">

	
	
		
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">发表评论 <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ics-design/#respond" style="display:none;">取消回复</a></small></h3><p class="must-log-in">要发表评论，您必须先<a href="http://blog.nsfocus.net/wp-login.php?redirect_to=http%3A%2F%2Fblog.nsfocus.net%2Fics-design%2F">登录</a>。</p>	</div><!-- #respond -->
	
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

	<div id="secondary" class="widget-area col-md-4" role="complementary">
				<aside id="countperday_popular_posts_widget-2" class="widget widget_countperday_popular_posts_widget"><b class="widget-title">热门文章</b><ul class="cpd_front_list"><li><a href="http://blog.nsfocus.net?p=8369">【获奖名单】参与话题赢权威报告</a> </li>
<li><a href="http://blog.nsfocus.net?p=1950">移动APP安全测试要点</a> </li>
<li><a href="http://blog.nsfocus.net?p=8705">【视频】TechWorld2017热点回顾 | 机器学习在安全攻防的实践</a> </li>
<li><a href="http://blog.nsfocus.net?p=8302">绿盟科技发布《2017上半年DDoS与Web应用攻击态势报告》</a> </li>
<li><a href="http://blog.nsfocus.net?p=505">Dedecms远程写文件漏洞分析</a> </li>
<li><a href="http://blog.nsfocus.net?p=5957">手把手简易实现shellcode及详解</a> </li>
<li><a href="http://blog.nsfocus.net?p=2737">Java反序列化漏洞详解</a> </li>
<li><a href="http://blog.nsfocus.net?p=8965">【预警通告】Apache Struts2（S2-052）远程代码执行漏洞</a> </li>
</ul></aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<b class="widget-title">最新文章</b>		<ul>
					<li>
				<a href="http://blog.nsfocus.net/struts2-s2-052-rest-plug-in-remote-code-execution-technical-analysis/">Struts2 s2-052 REST插件远程代码执行技术分析与防护方案</a>
						</li>
					<li>
				<a href="http://blog.nsfocus.net/finance-unknown-threat-detection/">金融行业未知威胁检测探知之道</a>
						</li>
					<li>
				<a href="http://blog.nsfocus.net/ics-design/">工业控制系统安全服务实施方法设计</a>
						</li>
					<li>
				<a href="http://blog.nsfocus.net/s2-052-struts2-remote-code-execution-vulnerability-4/">【预警通告】Apache Struts2（S2-052）远程代码执行漏洞</a>
						</li>
					<li>
				<a href="http://blog.nsfocus.net/kali-linux/">打磨渗透测试人员的利器Kali Linux</a>
						</li>
					<li>
				<a href="http://blog.nsfocus.net/sdp-iaas/">你或许不知道SDP 但它能改变IaaS安全现状</a>
						</li>
					<li>
				<a href="http://blog.nsfocus.net/4g-ddos/">当4G遇上DDoS 实战鹰眼溯源</a>
						</li>
					<li>
				<a href="http://blog.nsfocus.net/malware-sample-analysis-api/">恶意样本分析手册——API函数篇</a>
						</li>
				</ul>
		</aside>		<aside id="wysija-2" class="widget widget_wysija"><b class="widget-title">两步邮件订阅，方便获取文章</b><div class="widget_wysija_cont"><div id="msg-form-wysija-2" class="wysija-msg ajax"></div><form id="form-wysija-2" method="post" action="#wysija" class="widget_wysija">

欢迎订阅！现在已有1 907个朋友订阅了。<br />
在后续邮件的尾部，您可以退订及修改订阅内容。
<p class="wysija-checkbox-label">选择订阅组：</p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="3"  /> 最新文章</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="4"  /> 技术分享</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="5"  /> 漏洞分析</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="7"  /> 运维安全</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="6"  /> Web安全</label></p>

    <p class="wysija-checkbox-paragraph"><label><input class="wysija-checkbox validate[required]" name="wysija[user_list][list_id][]" type="checkbox" value="8"  /> 安全报告</label></p>

<p class="wysija-paragraph">
    <label>邮件 <span class="wysija-required">*</span></label>
    
    	<input type="text" name="wysija[user][email]" class="wysija-input validate[required,custom[email]]" title="邮件"  value="" />
    
    
    
    <span class="abs-req">
        <input type="text" name="wysija[user][abs][email]" class="wysija-input validated[abs][email]" value="" />
    </span>
    
</p>
<input class="wysija-submit wysija-submit-field" type="submit" value="马上订阅！" />

    <input type="hidden" name="form_id" value="1" />
    <input type="hidden" name="action" value="save" />
    <input type="hidden" name="controller" value="subscribers" />
    <input type="hidden" value="1" name="wysija-page" />

    
 </form></div></aside><aside id="nav_menu-2" class="widget widget_nav_menu"><b class="widget-title">友情链接</b><div class="menu-%e5%8f%8b%e6%83%85%e9%93%be%e6%8e%a5-container"><ul id="menu-%e5%8f%8b%e6%83%85%e9%93%be%e6%8e%a5" class="menu"><li id="menu-item-8155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8155"><a href="http://www.nsfocus.com.cn">绿盟科技官网</a></li>
</ul></div></aside>	</div><!-- #secondary -->

	</div><!-- #content -->

	<footer id="colophon" class="site-footer row" role="contentinfo">
	<div class="footer">
			<div class="site-info col-md-4 col-md-offset-3">
			&copy; 2017 <a href="http://www.nsfocus.com">NSFOCUS Corporation</a>, all rights reserved.
		</div><!-- .site-info -->
		
		<!-- <div id="footertext" class="col-md-7"> -->

       	        <!-- </div>   -->
      </div>
       <div class="foot-line"></div>
	</footer><!-- #colophon -->

</div><!-- #page -->

<script type="text/javascript">
// Count per Day
//<![CDATA[
var cpdTime = new Date().getTime() / 1000;
jQuery(document).ready( function()
{
	jQuery.get('/wp-admin/?page=cpd_ajax&f=count&cpage=8968&time='+cpdTime, function(text)
	{
		var cpd_funcs = text.split('|');
		for(var i = 0; i < cpd_funcs.length; i++)
		{
			var cpd_daten = cpd_funcs[i].split('===');
			var cpd_field = document.getElementById('cpd_number_' + cpd_daten[0].toLowerCase());
			if (cpd_field != null) { cpd_field.innerHTML = cpd_daten[1]; }
		}
	});
} );
//]]>
</script>


    <div id="wpfront-scroll-top-container"><img src="http://blog.nsfocus.net/wp-content/plugins/wpfront-scroll-top/images/icons/1.png" alt="" /></div>
    <script type="text/javascript">function wpfront_scroll_top_init() {if(typeof wpfront_scroll_top == "function" && typeof jQuery !== "undefined") {wpfront_scroll_top({"scroll_offset":100,"button_width":0,"button_height":0,"button_opacity":0.8,"button_fade_duration":200,"scroll_duration":400,"location":1,"marginX":20,"marginY":20,"hide_iframe":false,"auto_hide":false,"auto_hide_after":2});} else {setTimeout(wpfront_scroll_top_init, 100);}}wpfront_scroll_top_init();</script><div id="su-footer-links" style="text-align: center;"></div>
<p style="margin:0;padding:0;height:1px;overflow:hidden;">
    <script type="text/javascript"><!--
        var wumiiSitePrefix = "http://blog.nsfocus.net";
        var wumiiEnableCustomPos = false;
        var wumiiParams = "&num=8&mode=3&displayInFeed=1&version=1.0.5.7&pf=WordPress4.8.1";
        var wumiiCategories = ["\u5b89\u5168\u5206\u4eab"];
    //--></script><script type="text/javascript" src="http://widget.wumii.cn/ext/relatedItemsWidget"></script><a href="http://www.wumii.com/widget/relatedItems" style="border:0;"><img src="http://static.wumii.cn/images/pixel.png" alt="无觅相关文章插件，快速提升流量" style="border:0;padding:0;margin:0;" /></a>
</p><script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"http:\/\/blog.nsfocus.net\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"\u4f7f\u7528 %s \u590d\u5236\uff0c\u4f7f\u7528 %s \u7c98\u8d34\u3002","minimize":"\u70b9\u51fb\u5c55\u5f00\u4ee3\u7801"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js,wp-content/plugins/wp-category-tag-could/javascript/jquery.tagcanvas.min.js,wp-content/plugins/wp-category-tag-could/javascript/wpctc.tagcanvas.min.js,wp-content/plugins/wp-category-tag-could/javascript/jquery.style.min.js,wp-content/plugins/wp-category-tag-could/javascript/wp-category-tag-cloud.min.js,wp-content/themes/nsfocus/js/navigation.js,wp-content/themes/nsfocus/js/skip-link-focus-fix.js,wp-includes/js/comment-reply.min.js,wp-includes/js/wp-embed.min.js,wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"js","requestURL":"http:\/\/blog.nsfocus.net\/wp-admin\/admin-ajax.php","postID":"8968","nonce":"0d48723865"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blog.nsfocus.net/wp-content/plugins/post-views-counter/js/frontend.js?ver=1.2.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"auto","scroll_offset":"30"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wysijaAJAX = {"action":"wysija_ajax","controller":"subscribers","ajaxurl":"http:\/\/blog.nsfocus.net\/wp-admin\/admin-ajax.php","loadingTrans":"\u52a0\u8f7d\u4e2d...","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://blog.nsfocus.net/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js,wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js,wp-content/plugins/easy-table-of-contents/vendor/waypoints/jquery.waypoints.min.js,wp-content/plugins/easy-table-of-contents/assets/js/front.min.js,wp-content/plugins/wysija-newsletters/js/validate/languages/jquery.validationEngine-en.js,wp-content/plugins/wysija-newsletters/js/validate/jquery.validationEngine.js,wp-content/plugins/wysija-newsletters/js/front-subscribers.js'></script>
</body>
</html>
