Struts2 s2-052 REST插件远程代码执行技术分析与防护方案

2017年9月5日,Apache Struts发布最新的安全公告,Apache Struts 2.5.x以及之前的部分2.x版本的REST插件存在远程代码执行的高危漏洞,漏洞编号为CVE-2017-9805(S2-052)。漏洞的成因是由于使用XStreamHandler反序列化XStream实例的时候没有任何类型过滤导致远程代码执行。 阅读全文 “Struts2 s2-052 REST插件远程代码执行技术分析与防护方案” »