Apache Struts 2 Remote Code Execution Vulnerability (S2-046) Technical Analysis and Solution

In the wee hours of March 21, Apache Struts 2 released a security bulletin, announcing a remote code execution (RCE) vulnerability in the Jakarta Multipart parser, which has been assigned CVE-2017-5638.