「漏洞通告」VMware权限提升漏洞(CVE-2020-3950)

一、漏洞概述

3月17日,VMware官方发布编号为VMSA-2020-0005的安全公告,修复了存在于VMware Fusion,VMRC for Mac 和Horizon Client for Mac中的权限提升漏洞(CVE-2020-3950),由于VMware错误的使用了setuid,攻击者利用此漏洞可将目标系统中的普通用户权限提升至管理员权限。目前PoC已公开,建议相关用户升级版本进行防护。

漏洞复现成功的截图如下:

参考链接:

https://www.vmware.com/security/advisories/VMSA-2020-0005.html

二、影响范围

受影响版本

  • VMware Fusion < 11.5.2
  • VMware Remote Console for Mac <= 11.x
  • VMware Horizon Client for Mac < 5.4.0

不受影响版本

  • VMware Fusion = 11.5.2
  • VMware Remote Console for Mac = 11.0.1
  • VMware Horizon Client for Mac = 5.4.0

三、漏洞检测

3.1 版本检测

使用VMware软件的用户可以通过查看版本来判断是否在受影响范围内,以VMware Fusion为例,点击菜单“关于 VMWare Fusion”,即可查看当前应用软件的版本。

四、漏洞防护

4.1 官方升级

目前官方已在最新版本中修复了该漏洞,请受影响的用户升级版本进行防护,下载链接与说明文档如下:

修复版本下载链接说明文档
VMware Fusion 11.5.2https://www.vmware.com/go/downloadfusionhttps://docs.vmware.com/en/VMware-Fusion/index.html
VMware Horizon Client 5.4.0https://my.vmware.com/web/vmware/info/slug/desktop_end_user_computing/vmware_horizon_clients/5_0https://docs.vmware.com/en/VMware-Horizon-Client/index.html
VMware Remote Console 11.0.1 for Machttps://my.vmware.com/web/vmware/details?downloadGroup=VMRC1101&productId=742https://docs.vmware.com/en/VMware-Remote-Console/index.html

发表评论