【预警通告】OpenSSH信息泄露漏洞(CVE-2018-15473、CVE-2018-15919)

前段时间,OpenSSH被曝出存在两个信息泄露漏洞(CVE-2018-15473和CVE-2018-15919)。其中CVE-2018-15919影响自2011年9月6日发布的5.9版本到今年8月24日发布的最新版本7.8。CVE-2018-15473则影响自1999年以来至今年7.7版本中所有版本,远程攻击者可利用漏洞猜测在OpenSSH服务器上注册的用户名。

根据发现CVE-2018-15919的研究人员的说法,OpenSSH的开源开发人员表示并未将此信息泄露视为严重威胁,因为用户名被认为是用户身份的非秘密部分,因此在短时间内并未有修复计划。

漏洞描述

CVE-2018-15473

攻击者可以通过向目标系统发送身份验证请求数据包来利用此漏洞,成功的利用可能允许攻击者访问敏感信息,例如系统上的有效用户名。漏洞原因是

OpenSSH服务器在对包含了请求的数据包完全解析之前,不会延迟处理一个验证无效的用户。该漏洞和auth2-gss.c,auth2-hostbased.c,auth2-pubkey.c有关。

CVSS3 Base Score:5.3

CVSS3 Base Metrics:

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C

受影响的版本

  • OpenSSH <= 7.7

不受影响的版本

  • openssh-7.8p1-1.fc28 openssh-7.6p1-6.fc27

解决方案

建议用户升级到不受影响版本。且OpenBSD项目已在以下链接发布了源代码修复:https://github.com/openbsd/src/commit/779974d35b4859c07bc3cb8a12c74b43b0a7d1e0

参考链接:

https://tools.cisco.com/security/center/viewAlert.x?alertId=58762

CVE-2018-15919

该漏洞存在于OpenSSH的auth-gss2.c源代码文件中,是由于在受影响的系统上使用Guide Star Server II(GSS2)组件时对请求数据包验证不充分造成。攻击者可以通过向目标系统发送身份验证请求数据包来利用此漏洞。成功利用漏洞可能允许攻击者访问敏感信息,例如有效的用户名。

CVSS3 Base Score:5.3

CVSS3 Base Metrics:CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:P/RL:U/RC:R

受影响的版本

  • OpenSSH <= 7.8
  • OpenSSH >= 5.9

解决方案

OpenBSD项目尚未发布软件更新。

参考链接:

https://tools.cisco.com/security/center/viewAlert.x?alertId=58800

参考链接

https://securityaffairs.co/wordpress/75748/hacking/cve-2018-15919-username-enumeration-openssh.html

声 明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。

 

关于绿盟科技

北京神州绿盟信息安全科技股份有限公司(简称绿盟科技)成立于2000年4月,总部位于北京。在国内外设有30多个分支机构,为政府、运营商、金融、能源、互联网以及教育、医疗等行业用户,提供具有核心竞争力的安全产品及解决方案,帮助客户实现业务的安全顺畅运行。

基于多年的安全攻防研究,绿盟科技在网络及终端安全、互联网基础安全、合规及安全管理等领域,为客户提供入侵检测/防护、抗拒绝服务攻击、远程安全评估以及Web安全防护等产品以及专业安全服务。

北京神州绿盟信息安全科技股份有限公司于2014年1月29日起在深圳证券交易所创业板上市交易,股票简称:绿盟科技,股票代码:300369。

 

发表评论